aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/boost/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-07-04 01:21:51 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-07-04 01:21:53 +0200
commit23a96df0cedd7236fbd70087c8e3ee12b222040e (patch)
tree0e44ba075712704be5074a650dba01a9ab0b7cca /examples/boost/CMakeLists.txt
parentREADME & --help message updates (diff)
downloadcmake-common-23a96df0cedd7236fbd70087c8e3ee12b222040e.tar.gz
cmake-common-23a96df0cedd7236fbd70087c8e3ee12b222040e.zip
common.cmake: downgrade C++ standard versionv4.0
I was testing the new version (C++20) with some existing code, and immediately got build errors. Apparently, now this: const auto s = u8"hello"; means that s has the type of const char8_t *const, where char8_t is some batshit insanity with 0 backwards compatibility. For example, you cannot make a std::string out of this??? Fuck that, and fuck C++ committee morons.
Diffstat (limited to 'examples/boost/CMakeLists.txt')
-rw-r--r--examples/boost/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/boost/CMakeLists.txt b/examples/boost/CMakeLists.txt
index bfb1f68..e7ac156 100644
--- a/examples/boost/CMakeLists.txt
+++ b/examples/boost/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.12)
+cmake_minimum_required(VERSION 3.8)
project(example_boost)