aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/examples/dynamic/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-28 20:57:35 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-28 20:57:50 +0300
commit9989c9f8f1fac87798160203b8e674cbc44f5ff6 (patch)
tree89119bc764255dc0eb7e102804321f255de9fefa /examples/dynamic/CMakeLists.txt
parentMakefile: check symbols for examples/boost also (diff)
downloadcmake-common-9989c9f8f1fac87798160203b8e674cbc44f5ff6.tar.gz
cmake-common-9989c9f8f1fac87798160203b8e674cbc44f5ff6.zip
common.cmake: add install_pdbs()before_toolchain_refactoring
Diffstat (limited to 'examples/dynamic/CMakeLists.txt')
-rw-r--r--examples/dynamic/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/examples/dynamic/CMakeLists.txt b/examples/dynamic/CMakeLists.txt
index 4602adb..190b1c9 100644
--- a/examples/dynamic/CMakeLists.txt
+++ b/examples/dynamic/CMakeLists.txt
@@ -11,6 +11,4 @@ add_executable(foo foo.cpp)
target_link_libraries(foo PRIVATE baz)
install(TARGETS foo baz RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:foo>" "$<TARGET_PDB_FILE:baz>" DESTINATION bin OPTIONAL)
-endif()
+install_pdbs(TARGETS foo baz DESTINATION bin)