aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/debian
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-02-04 21:41:20 +0100
committerEgor Tensin <Egor.Tensin@gmail.com>2023-02-04 21:41:20 +0100
commite87c028b63cfc6822b606e6342c3f70d6399c650 (patch)
tree423f4e3e91e61805db80c8864513f2c01dac140d /debian
parentworkflows: prettify? (diff)
downloadlinux-status-e87c028b63cfc6822b606e6342c3f70d6399c650.tar.gz
linux-status-e87c028b63cfc6822b606e6342c3f70d6399c650.zip
debian/Makefile: use cd instead of pushd
Diffstat (limited to 'debian')
-rw-r--r--debian/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/debian/Makefile b/debian/Makefile
index a145c53..be3c513 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -61,40 +61,40 @@ commit:
.PHONY: tag
tag:
- pushd '$(call escape,$(root))' && gbp buildpackage --git-tag-only
+ cd -- '$(call escape,$(root))' && gbp buildpackage --git-tag-only
.PHONY: src/test
src/test:
- pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -S -us -uc
+ cd -- '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -S -us -uc
.PHONY: src
src:
- pushd '$(call escape,$(root))' && gbp buildpackage -S '-k0x$(call escape,$(GPG_KEY))'
+ cd -- '$(call escape,$(root))' && gbp buildpackage -S '-k0x$(call escape,$(GPG_KEY))'
.PHONY: bin/test
bin/test:
- pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -b -us -uc
+ cd -- '$(call escape,$(root))' && gbp buildpackage --git-ignore-new -b -us -uc
.PHONY: bin
bin:
- pushd '$(call escape,$(root))' && gbp buildpackage -b '-k0x$(call escape,$(GPG_KEY))'
+ cd -- '$(call escape,$(root))' && gbp buildpackage -b '-k0x$(call escape,$(GPG_KEY))'
.PHONY: dist/create
dist/create:
- pushd '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder create
+ cd -- '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder create
.PHONY: dist/update
dist/update:
- pushd '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder update
+ cd -- '$(call escape,$(root))' && env 'DIST=$(call escape,$(DIST))' git-pbuilder update
.PHONY: dist/test
dist/test:
- pushd '$(call escape,$(root))' && gbp buildpackage --git-ignore-new --git-pbuilder '--git-dist=$(call escape,$(DIST))'
+ cd -- '$(call escape,$(root))' && gbp buildpackage --git-ignore-new --git-pbuilder '--git-dist=$(call escape,$(DIST))'
.PHONY: dist
dist:
- pushd '$(call escape,$(root))' && gbp buildpackage --git-pbuilder '--git-dist=$(call escape,$(DIST))'
- pushd '$(call escape,$(root))' && debsign '-k0x$(call escape,$(GPG_KEY))' --debs-dir '$(call escape,$(build_area))'
+ cd -- '$(call escape,$(root))' && gbp buildpackage --git-pbuilder '--git-dist=$(call escape,$(DIST))'
+ cd -- '$(call escape,$(root))' && debsign '-k0x$(call escape,$(GPG_KEY))' --debs-dir '$(call escape,$(build_area))'
.PHONY: upload
upload: