aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-07-04 03:23:13 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-07-04 03:23:13 +0200
commit4e6e8d8c151c9eb7888927e816dc3756a600ec0f (patch)
treed31e0034ec19c1fb758348d14a5f1b37693da05c /CMakeLists.txt
parentMakefile: move the prelude to prelude.mk (diff)
downloadmath-server-4e6e8d8c151c9eb7888927e816dc3756a600ec0f.tar.gz
math-server-4e6e8d8c151c9eb7888927e816dc3756a600ec0f.zip
update cmake-common
Also, change the build directory to build/.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 027f3ec..84c4552 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,8 @@
-cmake_minimum_required(VERSION 3.8) # for C++17
+cmake_minimum_required(VERSION 3.8)
project(math_server CXX)
enable_testing()
-# C++17 is mandatory:
-set(CC_CXX_STANDARD 17)
-
include(cmake/common.cmake)
# AppVeyor builds w/ Visual Studio 2017 bombard me with stupid warnings otherwise: