aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-09 05:44:10 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-09 05:44:10 +0300
commita9c8bf6a19d5b4863a597a6723c6355031a61863 (patch)
tree13c764e50fd1c18713ae51eddfa7cdc82c244663 /CMakeLists.txt
parentupdate cmake-common (diff)
downloadmath-server-a9c8bf6a19d5b4863a597a6723c6355031a61863.tar.gz
math-server-a9c8bf6a19d5b4863a597a6723c6355031a61863.zip
CC_CXX_STANDARD -> CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11ee856..0c9c0a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,9 @@ project(math_server CXX)
option(ENABLE_TESTS "build the tests")
+# C++17 is mandatory:
+set(CC_CXX_STANDARD 17)
+
include(cmake/common.cmake)
add_subdirectory(client)