aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 22:43:39 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-04 22:43:39 +0300
commitc497f7ee387ea81ad47854015899beba0d6efbf1 (patch)
treec7e49bba4889c30c1eea25b22c955d9d9e6ae95d /CMakeLists.txt
parentcan't believe Boost::disable_autolinking isn't everywhere (diff)
downloadmath-server-c497f7ee387ea81ad47854015899beba0d6efbf1.tar.gz
math-server-c497f7ee387ea81ad47854015899beba0d6efbf1.zip
cmake: ENABLE_TESTS -> MATH_SERVER_TESTS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db0e2dc..8362ad2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.8) # for C++17
project(math_server CXX)
-option(ENABLE_TESTS "build the tests")
+option(MATH_SERVER_TESTS "build the tests")
# C++17 is mandatory:
set(CC_CXX_STANDARD 17)
@@ -30,7 +30,7 @@ endif()
add_subdirectory(client)
add_subdirectory(server)
-if(ENABLE_TESTS)
+if(MATH_SERVER_TESTS)
set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "Suppressing benchmark's tests" FORCE)
set(BENCHMARK_ENABLE_INSTALL OFF CACHE BOOL "Don't install benchmark the library" FORCE)
add_subdirectory("3rdparty/google/benchmark")