aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2019-12-13 00:27:25 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2019-12-13 00:30:00 +0300
commit354ed1ac85eeb50c6ae2f058b16a09d4fdd2f89c (patch)
tree5768f6d2e43efa0ceeb10909480ad9ff5f8e581e /client/CMakeLists.txt
parentAppVeyor: package artifacts (diff)
downloadmath-server-354ed1ac85eeb50c6ae2f058b16a09d4fdd2f89c.tar.gz
math-server-354ed1ac85eeb50c6ae2f058b16a09d4fdd2f89c.zip
rename executables
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index c76eba3..c6016b5 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -1,6 +1,7 @@
find_package(Boost REQUIRED COMPONENTS filesystem program_options)
add_executable(client main.cpp)
+
target_include_directories(client SYSTEM PRIVATE ${Boost_INCLUDE_DIRS})
target_link_libraries(client PRIVATE ${Boost_LIBRARIES})
target_compile_definitions(client PRIVATE BOOST_DATE_TIME_NO_LIB BOOST_REGEX_NO_LIB)
@@ -10,4 +11,6 @@ set(THREADS_PREFER_PTHREAD_FLAG ON)
find_package(Threads REQUIRED)
target_link_libraries(client PRIVATE Threads::Threads)
+set_target_properties(client PROPERTIES OUTPUT_NAME math-client)
+
install(TARGETS client RUNTIME DESTINATION bin)