aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/lexer/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-01-03 04:13:47 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-01-03 04:13:47 +0300
commit42820c4161edcabb1e36336d175bb8645f529df3 (patch)
treec65cec6d00a0494ea26b9f45903eb512f5e6e302 /server/lexer/CMakeLists.txt
parentcmake: don't install benchmark the library (diff)
downloadmath-server-42820c4161edcabb1e36336d175bb8645f529df3.tar.gz
math-server-42820c4161edcabb1e36336d175bb8645f529df3.zip
lexer: add alternative boost::regex implementations
Diffstat (limited to 'server/lexer/CMakeLists.txt')
-rw-r--r--server/lexer/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/server/lexer/CMakeLists.txt b/server/lexer/CMakeLists.txt
index b62e47a..b5b8b63 100644
--- a/server/lexer/CMakeLists.txt
+++ b/server/lexer/CMakeLists.txt
@@ -1,2 +1,5 @@
+find_package(Boost REQUIRED COMPONENTS regex)
+
add_library(lexer details/parse.cpp lexer.cpp token.cpp token_type.cpp)
target_link_libraries(lexer PUBLIC common)
+target_link_libraries(lexer PRIVATE Boost::regex)