aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5b81467..a956d03 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,2 +1,10 @@
add_subdirectory(benchmarks)
add_subdirectory(unit_tests)
+
+if(CMAKE_HOST_UNIX)
+ # Not going to bother with bash on Windows.
+
+ # stress_test.py is a Python 3 script.
+ find_package(Python3 REQUIRED COMPONENTS Interpreter)
+ add_test(NAME stress_test COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/stress_test.sh" "$<TARGET_FILE:server>" "$<TARGET_FILE:client>")
+endif()