aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 01:57:40 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 01:57:40 +0300
commit0e439fb2d229808a8d879bfefcf371099b522479 (patch)
treef2fc08d91f11cfae1dbd618be317b8d041f48903 /CMakeLists.txt
parentinitial commit (diff)
downloadwinapi-common-0e439fb2d229808a8d879bfefcf371099b522479.tar.gz
winapi-common-0e439fb2d229808a8d879bfefcf371099b522479.zip
add Handle class
It's derived from various projects of mine.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ef5747e
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
+
+project(winapi_common CXX)
+
+include(cmake/common.cmake)
+
+find_package(Boost REQUIRED)
+
+add_library(winapi_common INTERFACE)
+target_include_directories(winapi_common INTERFACE include/)
+target_link_libraries(winapi_common INTERFACE Boost::disable_autolinking Boost::headers)
+
+install(DIRECTORY include/winapi DESTINATION include)
+
+if(WINAPI_COMMON_TESTS)
+ add_subdirectory(test)
+endif()
+
+install(FILES LICENSE.txt DESTINATION share)