aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-04-03 14:50:44 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-04-06 21:30:44 +0300
commit821ae8000593e2c33724530216217daad8d02835 (patch)
treec746fde20ab240f8f4ad40361b69c55b605ab675 /CMakeLists.txt
parentcmake: use install_pdbs() (diff)
downloadwinapi-common-821ae8000593e2c33724530216217daad8d02835.tar.gz
winapi-common-821ae8000593e2c33724530216217daad8d02835.zip
add CTest tests, add `make test`, etc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6a4357..3fc3b4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
project(winapi_common CXX)
+enable_testing()
+
include(cmake/common.cmake)
file(GLOB_RECURSE winapi_common_include "include/*.hpp")