aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-02-24 21:16:48 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-02-24 21:48:54 +0300
commita64964a2219bdfe5906b9de3838d0b97e1b1edb5 (patch)
treec2ddeeeecfda89eb6883dcef494a141c65a095f3 /CMakeLists.txt
parentadd README.md (diff)
downloadwinapi-common-a64964a2219bdfe5906b9de3838d0b97e1b1edb5.tar.gz
winapi-common-a64964a2219bdfe5906b9de3838d0b97e1b1edb5.zip
use SafeInt to make integers a bit more safe
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4a839b..c6a4357 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,11 @@ target_include_directories(winapi_common PUBLIC include)
add_subdirectory(3rdparty/winapi/utf8 EXCLUDE_FROM_ALL)
target_link_libraries(winapi_common PRIVATE winapi_utf8)
+if(NOT TARGET SafeInt)
+ add_subdirectory(3rdparty/microsoft/SafeInt EXCLUDE_FROM_ALL)
+endif()
+target_link_libraries(winapi_common PUBLIC SafeInt)
+
find_package(Boost REQUIRED)
target_link_libraries(winapi_common PUBLIC Boost::boost)