aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-05-16 22:50:45 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-05-16 22:50:45 +0300
commit9106d21e4be128937f31b98becae4eb0c0716f77 (patch)
treeeafa72955e4d27d41793eae89ab15fc4e47d7cd8 /test/CMakeLists.txt
parentadd .clang-tidy, `make check` (diff)
downloadwinapi-common-9106d21e4be128937f31b98becae4eb0c0716f77.tar.gz
winapi-common-9106d21e4be128937f31b98becae4eb0c0716f77.zip
test: echo is _not_ MSVC-only, all of a sudden
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ed1ebab..396356d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,10 +1,10 @@
-# echo.cpp is MSVC-only, I think.
-# TODO: fix that?
-if(MSVC)
- add_executable(echo echo.cpp)
- set_target_properties(echo PROPERTIES OUTPUT_NAME winapi-common-test-echo)
- install(TARGETS echo RUNTIME DESTINATION bin)
- install_pdbs(TARGETS echo DESTINATION bin)
-
- add_subdirectory(unit_tests)
+add_executable(echo echo.cpp)
+set_target_properties(echo PROPERTIES OUTPUT_NAME winapi-common-test-echo)
+install(TARGETS echo RUNTIME DESTINATION bin)
+install_pdbs(TARGETS echo DESTINATION bin)
+if(MINGW)
+ target_compile_options(echo PRIVATE -municode)
+ target_link_libraries(echo PRIVATE -municode)
endif()
+
+add_subdirectory(unit_tests)