aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 21:26:58 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 21:26:58 +0300
commitbf5602a8cf0ed86fd37191824c1323a9d17ed415 (patch)
tree2809d82aa5e5f93b560c2775b767609b03b8bc99 /test/CMakeLists.txt
parentworkflows/ci: Bionic to Focal (diff)
downloadwinapi-common-bf5602a8cf0ed86fd37191824c1323a9d17ed415.tar.gz
winapi-common-bf5602a8cf0ed86fd37191824c1323a9d17ed415.zip
cmake: use install_pdbs()
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 43b4d4d..3b61d11 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,8 +2,6 @@ add_executable(echo echo.cpp)
set_target_properties(echo PROPERTIES OUTPUT_NAME winapi-common-test-echo)
install(TARGETS echo RUNTIME DESTINATION bin)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:echo>" DESTINATION bin OPTIONAL)
-endif()
+install_pdbs(TARGETS echo DESTINATION bin)
add_subdirectory(unit_tests)