aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0244ce4..c4a839b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,10 +4,10 @@ project(winapi_common CXX)
include(cmake/common.cmake)
-file(GLOB winapi_common_cpp "src/*.cpp")
-file(GLOB_RECURSE winapi_common_hpp "include/*.hpp")
-add_library(winapi_common ${winapi_common_cpp} ${winapi_common_hpp})
-target_include_directories(winapi_common PUBLIC include/)
+file(GLOB_RECURSE winapi_common_include "include/*.hpp")
+file(GLOB winapi_common_src "src/*.cpp")
+add_library(winapi_common ${winapi_common_include} ${winapi_common_src})
+target_include_directories(winapi_common PUBLIC include)
add_subdirectory(3rdparty/winapi/utf8 EXCLUDE_FROM_ALL)
target_link_libraries(winapi_common PRIVATE winapi_utf8)