aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index bed23ce..a46bf49 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1 +1,9 @@
+add_executable(args args.cpp)
+set_target_properties(args PROPERTIES OUTPUT_NAME winapi-common-test-args)
+
+install(TARGETS args RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:args>" DESTINATION bin OPTIONAL)
+endif()
+
add_subdirectory(unit_tests)