aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3b61d11..ed1ebab 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,7 +1,10 @@
-add_executable(echo echo.cpp)
-set_target_properties(echo PROPERTIES OUTPUT_NAME winapi-common-test-echo)
+# echo.cpp is MSVC-only, I think.
+# TODO: fix that?
+if(MSVC)
+ add_executable(echo echo.cpp)
+ set_target_properties(echo PROPERTIES OUTPUT_NAME winapi-common-test-echo)
+ install(TARGETS echo RUNTIME DESTINATION bin)
+ install_pdbs(TARGETS echo DESTINATION bin)
-install(TARGETS echo RUNTIME DESTINATION bin)
-install_pdbs(TARGETS echo DESTINATION bin)
-
-add_subdirectory(unit_tests)
+ add_subdirectory(unit_tests)
+endif()