aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/unit_tests/CMakeLists.txt')
-rw-r--r--test/unit_tests/CMakeLists.txt18
1 files changed, 17 insertions, 1 deletions
diff --git a/test/unit_tests/CMakeLists.txt b/test/unit_tests/CMakeLists.txt
index fb87230..7311d75 100644
--- a/test/unit_tests/CMakeLists.txt
+++ b/test/unit_tests/CMakeLists.txt
@@ -1,5 +1,7 @@
+file(GLOB shared_src "shared/*.hpp")
+
file(GLOB unit_tests_src "*.cpp" "*.h" "*.hpp" "*.rc")
-add_executable(unit_tests ${unit_tests_src})
+add_executable(unit_tests ${unit_tests_src} ${shared_src})
set_target_properties(unit_tests PROPERTIES OUTPUT_NAME winapi-common-unit-tests)
target_link_libraries(unit_tests PRIVATE winapi_common winapi_utf8)
@@ -11,3 +13,17 @@ install(TARGETS unit_tests RUNTIME DESTINATION bin)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)
endif()
+
+file(GLOB worker_src "worker/*.cpp")
+add_executable(worker ${worker_src} ${shared_src})
+set_target_properties(worker PROPERTIES OUTPUT_NAME winapi-common-test-worker)
+
+target_link_libraries(worker PRIVATE winapi_common winapi_utf8)
+
+find_package(Boost REQUIRED)
+target_link_libraries(worker PRIVATE Boost::disable_autolinking Boost::boost)
+
+install(TARGETS worker RUNTIME DESTINATION bin)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:worker>" DESTINATION bin OPTIONAL)
+endif()