aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-05-15 23:05:10 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-05-15 23:05:10 +0300
commit84ea7c37b2b9e1eb71ef812fffc569bb98ec82cf (patch)
treea3449960508c9da666c792a49f1f98dbe351d589 /CMakeLists.txt
parentswitch from Boost.Nowide to winapi-utf8 (diff)
downloadwinapi-debug-84ea7c37b2b9e1eb71ef812fffc569bb98ec82cf.tar.gz
winapi-debug-84ea7c37b2b9e1eb71ef812fffc569bb98ec82cf.zip
rename the project
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fcad15..20e528a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
-project(pdb_repo CXX)
+project(winapi_debug CXX)
enable_testing()
if(MSVC)
@@ -29,28 +29,28 @@ include(cmake/common.cmake)
find_package(Boost REQUIRED)
add_subdirectory(3rdparty/winapi/utf8)
-file(GLOB_RECURSE pdb_repo_include "include/*.hpp")
-file(GLOB_RECURSE pdb_repo_src "src/*.cpp")
-add_library(pdb_repo ${pdb_repo_include} ${pdb_repo_src})
-target_compile_definitions(pdb_repo PUBLIC _NO_CVCONST_H)
-target_include_directories(pdb_repo PUBLIC include/)
-target_link_libraries(pdb_repo PRIVATE winapi_utf8)
-target_link_libraries(pdb_repo
+file(GLOB_RECURSE winapi_debug_include "include/*.hpp")
+file(GLOB_RECURSE winapi_debug_src "src/*.cpp")
+add_library(winapi_debug ${winapi_debug_include} ${winapi_debug_src})
+target_compile_definitions(winapi_debug PUBLIC _NO_CVCONST_H)
+target_include_directories(winapi_debug PUBLIC include/)
+target_link_libraries(winapi_debug PRIVATE winapi_utf8)
+target_link_libraries(winapi_debug
PUBLIC Boost::boost
PRIVATE Boost::disable_autolinking)
-target_link_libraries(pdb_repo PRIVATE dbghelp)
+target_link_libraries(winapi_debug PRIVATE dbghelp)
if(MINGW)
# FILE_ID_INFO and friends require at least 0x0602:
message("MINGW")
- target_compile_definitions(pdb_repo PUBLIC
+ target_compile_definitions(winapi_debug PUBLIC
NTDDI_VERSION=NTDDI_WIN8
_WIN32_WINNT=_WIN32_WINNT_WIN8)
endif()
if(MSVC_VERSION EQUAL 1900)
# DbgHelp warnings on Visual Studio 2015:
- target_compile_options(pdb_repo PUBLIC /wd4091)
+ target_compile_options(winapi_debug PUBLIC /wd4091)
endif()
add_subdirectory(test)