aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-05-29 01:44:43 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-05-29 01:44:43 +0300
commitbe80d87319ecdad861876efa173b4c576b4e0ea3 (patch)
tree3f463eca4e94f99e7199da23b5091137cb000396 /CMakeLists.txt
parentmove _address functions to winapi::address (diff)
downloadwinapi-debug-be80d87319ecdad861876efa173b4c576b4e0ea3.tar.gz
winapi-debug-be80d87319ecdad861876efa173b4c576b4e0ea3.zip
cmake: add install() commands
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a80fec..6df0992 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,8 @@ target_link_libraries(winapi_debug
PUBLIC Boost::boost
PRIVATE Boost::disable_autolinking)
target_link_libraries(winapi_debug PRIVATE dbghelp)
+INSTALL(TARGETS winapi_debug ARCHIVE DESTINATION lib)
+install(DIRECTORY include/winapi DESTINATION include)
if(MSVC_VERSION EQUAL 1900)
# DbgHelp warnings on Visual Studio 2015: