aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2017-05-17 06:00:20 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2017-05-17 06:00:20 +0300
commitc67055bad3cdfc93e2ac57d87f36c6e0993af690 (patch)
treeda8759c66f1af00415784e5824e6bfc2195aee92 /CMakeLists.txt
downloadwinapi-debug-c67055bad3cdfc93e2ac57d87f36c6e0993af690.tar.gz
winapi-debug-c67055bad3cdfc93e2ac57d87f36c6e0993af690.zip
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..67194a1
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
+project(pdb_repo CXX)
+
+include(common.cmake)
+
+file(GLOB_RECURSE pdb_repo_include "include/*.hpp")
+file(GLOB_RECURSE pdb_repo_src "src/*.cpp")
+add_library(pdb_repo ${pdb_repo_include} ${pdb_repo_src})
+target_compile_definitions(pdb_repo PRIVATE NOMINMAX PUBLIC _NO_CVCONST_H)
+target_include_directories(pdb_repo PUBLIC include/)
+target_link_libraries(pdb_repo PRIVATE DbgHelp)
+
+if(MSVC_VERSION EQUAL 1900)
+ # These annoying DbgHelp.h warnings:
+ # https://connect.microsoft.com/VisualStudio/feedback/details/888527/warnings-on-dbghelp-h
+ target_compile_options(pdb_repo PUBLIC /wd4091)
+endif()
+
+add_subdirectory(utils)