aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-03-24 00:43:34 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-03-24 00:48:16 +0300
commiteaf76a222e709f81e9d7c71b6c47ee172604af05 (patch)
treebf2fd37b9f5e4c6805d05be219d41d75156245cc /CMakeLists.txt
parentTravis: incremental Docker builds (diff)
downloadwinapi-debug-eaf76a222e709f81e9d7c71b6c47ee172604af05.tar.gz
winapi-debug-eaf76a222e709f81e9d7c71b6c47ee172604af05.zip
add Process class
It's intended to be used for the future dump writing functionality, to generate a meaningful file name, etc. Also, add Boost.Nowide, which provides handy UTF-8 conversion functions. I'm not sure about this, but things indicate that it's about to be included in Boost.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8af82e9..5ad6d0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,9 +2,10 @@ cmake_minimum_required(VERSION 3.5) # for Boost::* imported targets
project(pdb_repo CXX)
-include(cmake/cmake/common.cmake)
-
find_package(Boost REQUIRED)
+add_subdirectory(3rdparty/boost/nowide)
+
+include(cmake/cmake/common.cmake)
file(GLOB_RECURSE pdb_repo_include "include/*.hpp")
file(GLOB_RECURSE pdb_repo_src "src/*.cpp")
@@ -12,7 +13,7 @@ add_library(pdb_repo ${pdb_repo_include} ${pdb_repo_src})
target_compile_definitions(pdb_repo PUBLIC _NO_CVCONST_H)
target_include_directories(pdb_repo PUBLIC include/)
target_include_directories(pdb_repo SYSTEM PUBLIC 3rdparty/microsoft/SafeInt)
-target_link_libraries(pdb_repo PUBLIC Boost::boost)
+target_link_libraries(pdb_repo PUBLIC Boost::boost PRIVATE Boost::nowide)
target_link_libraries(pdb_repo PRIVATE dbghelp)
if(MINGW)