aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-03-24 19:22:40 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-03-27 11:25:22 +0300
commit10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34 (patch)
tree13cb9beac308afab5ec1188bb73f28beb64eafe2 /test/CMakeLists.txt
parentfix a bug where I failed to account for TCHARs, again (diff)
downloadwinapi-debug-10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34.tar.gz
winapi-debug-10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34.zip
add some unit tests
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ac3e8b3..c4406c8 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,16 +2,16 @@ add_executable(call_stack call_stack.cpp)
target_link_libraries(call_stack PRIVATE pdb_repo)
target_link_libraries(call_stack PRIVATE Boost::nowide)
-install(TARGETS call_stack RUNTIME DESTINATION bin)
+install(TARGETS call_stack RUNTIME DESTINATION bin/test)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:call_stack>" DESTINATION bin OPTIONAL)
+ install(FILES "$<TARGET_PDB_FILE:call_stack>" DESTINATION bin/test OPTIONAL)
endif()
-set(CC_STATIC_RUNTIME OFF) # Reduce the number of symbols in this test utility
-
add_executable(symbols symbols.cpp)
-install(TARGETS symbols RUNTIME DESTINATION bin)
+install(TARGETS symbols RUNTIME DESTINATION bin/test)
if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:symbols>" DESTINATION bin OPTIONAL)
+ install(FILES "$<TARGET_PDB_FILE:symbols>" DESTINATION bin/test OPTIONAL)
endif()
+
+add_subdirectory(unit_tests)