aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-03-24 19:22:40 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-03-27 11:25:22 +0300
commit10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34 (patch)
tree13cb9beac308afab5ec1188bb73f28beb64eafe2 /test/unit_tests/CMakeLists.txt
parentfix a bug where I failed to account for TCHARs, again (diff)
downloadwinapi-debug-10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34.tar.gz
winapi-debug-10b3c9e5a8ce46cfbc3c80042fcaf6079f6a8a34.zip
add some unit tests
Diffstat (limited to 'test/unit_tests/CMakeLists.txt')
-rw-r--r--test/unit_tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/unit_tests/CMakeLists.txt b/test/unit_tests/CMakeLists.txt
new file mode 100644
index 0000000..e7362e1
--- /dev/null
+++ b/test/unit_tests/CMakeLists.txt
@@ -0,0 +1,10 @@
+find_package(Boost REQUIRED COMPONENTS filesystem unit_test_framework)
+
+add_executable(unit_tests main.cpp dbghelp.cpp error.cpp)
+target_link_libraries(unit_tests PRIVATE pdb_repo)
+target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::filesystem Boost::nowide Boost::unit_test_framework)
+
+install(TARGETS unit_tests RUNTIME DESTINATION bin/test)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
+ install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin/test OPTIONAL)
+endif()