aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-04-07 00:42:46 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-04-07 00:42:46 +0300
commit77df1f06d7a60f8a8b23f362344f256608cc20bf (patch)
treeba8b13770fe25199a609ce5517133fdd2391894f /test/unit_tests/CMakeLists.txt
parentadd `make install`, `make test`, etc. (diff)
downloadwinapi-debug-77df1f06d7a60f8a8b23f362344f256608cc20bf.tar.gz
winapi-debug-77df1f06d7a60f8a8b23f362344f256608cc20bf.zip
cmake: slight CMakeLists.txt refactoring
Diffstat (limited to 'test/unit_tests/CMakeLists.txt')
-rw-r--r--test/unit_tests/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/test/unit_tests/CMakeLists.txt b/test/unit_tests/CMakeLists.txt
index 135087b..bfeab62 100644
--- a/test/unit_tests/CMakeLists.txt
+++ b/test/unit_tests/CMakeLists.txt
@@ -2,15 +2,21 @@ find_package(Boost REQUIRED COMPONENTS filesystem unit_test_framework)
add_executable(unit_tests main.cpp call_stack.cpp dbghelp.cpp error.cpp)
target_link_libraries(unit_tests PRIVATE pdb_repo test_lib)
-target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::filesystem Boost::nowide Boost::unit_test_framework)
-
+target_link_libraries(unit_tests PRIVATE
+ Boost::disable_autolinking
+ Boost::filesystem
+ Boost::nowide
+ Boost::unit_test_framework)
install(TARGETS unit_tests RUNTIME DESTINATION bin/test)
install_pdbs(TARGETS unit_tests DESTINATION bin/test)
if(MSVC)
# Set the working directory so that the unit_tests binary can find the
# test_lib shared library binary.
- add_test(NAME unit_tests
- COMMAND unit_tests --log_level=all --no_color_output -- --test_lib_pdb "$<TARGET_PDB_FILE:test_lib>"
- WORKING_DIRECTORY "$<TARGET_FILE_DIR:test_lib>")
+ add_test(NAME unit_tests COMMAND unit_tests
+ --log_level=all
+ --no_color_output
+ --
+ --test_lib_pdb "$<TARGET_PDB_FILE:test_lib>"
+ WORKING_DIRECTORY "$<TARGET_FILE_DIR:test_lib>")
endif()