aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-08 12:30:29 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-08 12:30:29 +0300
commit1c5dcd19b15c2cec9141502fc9d3d28674909505 (patch)
tree03a66b16830dfba9e44fba974ed1e26816253d42 /CMakeLists.txt
parentadd Travis configuration (diff)
downloadwinapi-utf8-1c5dcd19b15c2cec9141502fc9d3d28674909505.tar.gz
winapi-utf8-1c5dcd19b15c2cec9141502fc9d3d28674909505.zip
Travis: define NTDDI_VERSION, etc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa0b876..5588dd6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,13 @@ file(GLOB winapi_utf8_src "src/*.cpp")
add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
target_include_directories(winapi_utf8 PUBLIC include/)
+# Vista is the lower bound (due to WC_ERR_INVALID_CHARS):
+if(MINGW)
+ target_compile_definitions(winapi_utf8 PRIVATE
+ NTDDI_VERSION=NTDDI_VISTA
+ _WIN32_WINNT=_WIN32_WINNT_VISTA)
+endif()
+
install(TARGETS winapi_utf8 ARCHIVE DESTINATION lib)
install(DIRECTORY include/winapi DESTINATION include)