aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 10:41:44 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-14 10:41:44 +0300
commit696beed48046507329f6d2b9e35ba5cf56df59ff (patch)
tree1f58d55fd095f12f1e9400199a2f8058ff960ace /CMakeLists.txt
parentupdate cmake-common (diff)
downloadwinapi-utf8-696beed48046507329f6d2b9e35ba5cf56df59ff.tar.gz
winapi-utf8-696beed48046507329f6d2b9e35ba5cf56df59ff.zip
cmake: don't install SafeInt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c868a3b..2d38a36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,12 +4,12 @@ project(winapi_utf8 CXX)
include(cmake/common.cmake)
-add_subdirectory(3rdparty/microsoft/SafeInt)
-
file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
file(GLOB winapi_utf8_src "src/*.cpp")
add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
target_include_directories(winapi_utf8 PUBLIC include/)
+
+add_subdirectory(3rdparty/microsoft/SafeInt EXCLUDE_FROM_ALL)
target_link_libraries(winapi_utf8 PRIVATE SafeInt)
# Vista is the lower bound (due to WC_ERR_INVALID_CHARS):