aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 21:27:32 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2021-03-24 21:27:32 +0300
commit973392427b70b5ee6d17b027e05a2f77e6a4a919 (patch)
tree5134ef2d9bad06a683ebeb8395b77e99dc232bff /test/CMakeLists.txt
parentworkflows/ci: Bionic to Focal (diff)
downloadwinapi-utf8-973392427b70b5ee6d17b027e05a2f77e6a4a919.tar.gz
winapi-utf8-973392427b70b5ee6d17b027e05a2f77e6a4a919.zip
cmake: use install_pdbs()
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d23dc87..a94e71d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -8,8 +8,6 @@ find_package(Boost REQUIRED COMPONENTS unit_test_framework)
target_link_libraries(unit_tests PRIVATE Boost::disable_autolinking Boost::unit_test_framework)
install(TARGETS unit_tests RUNTIME DESTINATION bin)
-if(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- install(FILES "$<TARGET_PDB_FILE:unit_tests>" DESTINATION bin OPTIONAL)
-endif()
+install_pdbs(TARGETS unit_tests DESTINATION bin)
add_test(NAME unit_tests COMMAND unit_tests)