aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d43a1aa..555e0b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,9 @@ file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
file(GLOB winapi_utf8_src "src/*.cpp")
add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
target_include_directories(winapi_utf8 PUBLIC include/)
-install(TARGETS winapi_utf8 LIBRARY DESTINATION lib)
+
+install(TARGETS winapi_utf8 ARCHIVE DESTINATION lib)
+install(DIRECTORY include/winapi DESTINATION include)
if(WINAPI_UTF8_ENABLE_TESTS)
add_subdirectory(test)