aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/um/wrappers/special/nt_namespace/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2017-04-28 17:48:44 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2017-04-28 17:48:44 +0300
commit040444db8fc48cd4012bc7ec4568f6a9b6143cb3 (patch)
tree82fe63ebc8f4e505d9337345cf67704bd60e9834 /um/wrappers/special/nt_namespace/CMakeLists.txt
parentCMakeLists.txt updates (diff)
downloadwindows7-drivers-040444db8fc48cd4012bc7ec4568f6a9b6143cb3.tar.gz
windows7-drivers-040444db8fc48cd4012bc7ec4568f6a9b6143cb3.zip
nt_path_converter -> nt_namespace
Diffstat (limited to 'um/wrappers/special/nt_namespace/CMakeLists.txt')
-rw-r--r--um/wrappers/special/nt_namespace/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/um/wrappers/special/nt_namespace/CMakeLists.txt b/um/wrappers/special/nt_namespace/CMakeLists.txt
new file mode 100644
index 0000000..ede2673
--- /dev/null
+++ b/um/wrappers/special/nt_namespace/CMakeLists.txt
@@ -0,0 +1,10 @@
+project(libnt_namespace)
+file(GLOB libnt_namespace_sources "src/*.cpp")
+file(GLOB_RECURSE libnt_namespace_headers "include/*.hpp")
+add_library(libnt_namespace
+ ${libnt_namespace_sources}
+ ${libnt_namespace_headers})
+target_link_libraries(libnt_namespace libservice)
+target_include_directories(libnt_namespace PUBLIC include/)
+
+add_subdirectory(utils)