aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/um/wrappers/special/nt_path_converter/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2017-04-27 22:35:21 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2017-04-27 22:35:21 +0300
commit7be3d976a223220e8e48896a401ac7e56e40ce62 (patch)
tree4d39e948d5ccd65c27d6ce76120bbcbe33484061 /um/wrappers/special/nt_path_converter/CMakeLists.txt
parentmove WDK-version-specific stuff out of root README (diff)
downloadwindows7-drivers-7be3d976a223220e8e48896a401ac7e56e40ce62.tar.gz
windows7-drivers-7be3d976a223220e8e48896a401ac7e56e40ce62.zip
um: reorganize projects
* libservice -> service * libsimple -> wrappers/simple * libnt_path_converter -> wrappers/special/nt_path_converter
Diffstat (limited to 'um/wrappers/special/nt_path_converter/CMakeLists.txt')
-rw-r--r--um/wrappers/special/nt_path_converter/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/um/wrappers/special/nt_path_converter/CMakeLists.txt b/um/wrappers/special/nt_path_converter/CMakeLists.txt
new file mode 100644
index 0000000..69f85d0
--- /dev/null
+++ b/um/wrappers/special/nt_path_converter/CMakeLists.txt
@@ -0,0 +1,10 @@
+project(libnt_path_converter)
+file(GLOB libnt_path_converter_sources "src/*.cpp")
+file(GLOB_RECURSE libnt_path_converter_headers "include/*.hpp")
+add_library(libnt_path_converter
+ ${libnt_path_converter_sources}
+ ${libnt_path_converter_headers})
+target_link_libraries(libnt_path_converter libservice)
+target_include_directories(libnt_path_converter PUBLIC include/)
+
+add_subdirectory(utils)