aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2015-05-25 02:40:04 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2015-05-25 02:40:04 +0300
commitd84140f48f9180fce594ee77e288bd6bbfc11fc9 (patch)
treee205952da2a68b7d8f2e504e1774b47074f77643 /test/CMakeLists.txt
parentadd block parsing functions (diff)
downloadaes-tools-d84140f48f9180fce594ee77e288bd6bbfc11fc9.tar.gz
aes-tools-d84140f48f9180fce594ee77e288bd6bbfc11fc9.zip
add test/
Includes simple block encryption/decryption programs for the supported modes (AES128/192/256 ECB + AES256 CBC).
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..cba5d79
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /SAFESEH:NO")
+
+macro(test prefix)
+ add_executable(${prefix}_encrypt_block ${prefix}_encrypt_block.c)
+ target_link_libraries(${prefix}_encrypt_block libaesni)
+
+ add_executable(${prefix}_decrypt_block ${prefix}_decrypt_block.c)
+ target_link_libraries(${prefix}_decrypt_block libaesni)
+endmacro()
+
+test(aes128ecb)
+test(aes192ecb)
+test(aes256ecb)
+test(aes256cbc)