aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..cba5d79
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /SAFESEH:NO")
+
+macro(test prefix)
+ add_executable(${prefix}_encrypt_block ${prefix}_encrypt_block.c)
+ target_link_libraries(${prefix}_encrypt_block libaesni)
+
+ add_executable(${prefix}_decrypt_block ${prefix}_decrypt_block.c)
+ target_link_libraries(${prefix}_decrypt_block libaesni)
+endmacro()
+
+test(aes128ecb)
+test(aes192ecb)
+test(aes256ecb)
+test(aes256cbc)