aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2023-07-26 13:26:07 +0200
committerEgor Tensin <Egor.Tensin@gmail.com>2023-07-26 13:27:32 +0200
commitb4d9abd90a8977d93104621840c143a5c5ccce82 (patch)
tree26be6b340f2398d2e88457f44227c2bd9b097ea8 /CMakeLists.txt
parenttest: test a weird exit code (diff)
downloadcimple-b4d9abd90a8977d93104621840c143a5c5ccce82.tar.gz
cimple-b4d9abd90a8977d93104621840c143a5c5ccce82.zip
never omit frame pointer
This optimization is honestly just evil. Even a whole distro thinks that: https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64efa33..755ead3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@ enable_testing()
add_compile_options(-std=c17 -Wpedantic -Wall -Wextra)
add_compile_options($<$<NOT:$<CONFIG:Debug>>:-Werror>)
+add_compile_options(-fno-omit-frame-pointer -mno-omit-leaf-frame-pointer)
+
add_subdirectory(src)
add_subdirectory(test)