aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/server/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'server/common/CMakeLists.txt')
-rw-r--r--server/common/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/server/common/CMakeLists.txt b/server/common/CMakeLists.txt
new file mode 100644
index 0000000..5655861
--- /dev/null
+++ b/server/common/CMakeLists.txt
@@ -0,0 +1,6 @@
+find_package(Boost REQUIRED)
+
+add_library(common INTERFACE)
+
+target_include_directories(common SYSTEM INTERFACE ${Boost_INCLUDE_DIRS})
+target_link_libraries(common INTERFACE ${Boost_LIBRARIES})