aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2020-10-17 10:31:34 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2020-10-17 10:31:34 +0300
commite1b5fe8226faca994a6d2b6302c7f18cb78133e3 (patch)
tree84eb597be1dbec4f68e8b9f8897e0ad042abd24b /CMakeLists.txt
parentcmake: don't install SafeInt (diff)
downloadwinapi-utf8-e1b5fe8226faca994a6d2b6302c7f18cb78133e3.tar.gz
winapi-utf8-e1b5fe8226faca994a6d2b6302c7f18cb78133e3.zip
cmake: best practices
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d38a36..70d7a72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,9 +4,9 @@ project(winapi_utf8 CXX)
include(cmake/common.cmake)
-file(GLOB_RECURSE winapi_utf8_include "include/*.hpp")
-file(GLOB winapi_utf8_src "src/*.cpp")
-add_library(winapi_utf8 ${winapi_utf8_include} ${winapi_utf8_src})
+file(GLOB_RECURSE winapi_utf8_hpp "include/*.hpp")
+file(GLOB winapi_utf8_cpp "src/*.cpp")
+add_library(winapi_utf8 ${winapi_utf8_hpp} ${winapi_utf8_cpp})
target_include_directories(winapi_utf8 PUBLIC include/)
add_subdirectory(3rdparty/microsoft/SafeInt EXCLUDE_FROM_ALL)