aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/um/wrappers/special/nt_namespace/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Tensin <Egor.Tensin@gmail.com>2017-04-29 14:10:29 +0300
committerEgor Tensin <Egor.Tensin@gmail.com>2017-04-29 14:10:29 +0300
commit1fa2e67e227b64bc316c66eb79c389b032bf941f (patch)
treeaf0794a51eebdfe72efdc47be0d06f8fdd74edd0 /um/wrappers/special/nt_namespace/utils/CMakeLists.txt
parentnt_path_converter -> nt_namespace (diff)
downloadwindows7-drivers-1fa2e67e227b64bc316c66eb79c389b032bf941f.tar.gz
windows7-drivers-1fa2e67e227b64bc316c66eb79c389b032bf941f.zip
um: strip the 'lib' prefix from CMake targets
Diffstat (limited to 'um/wrappers/special/nt_namespace/utils/CMakeLists.txt')
-rw-r--r--um/wrappers/special/nt_namespace/utils/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/um/wrappers/special/nt_namespace/utils/CMakeLists.txt b/um/wrappers/special/nt_namespace/utils/CMakeLists.txt
index 294a713..9657693 100644
--- a/um/wrappers/special/nt_namespace/utils/CMakeLists.txt
+++ b/um/wrappers/special/nt_namespace/utils/CMakeLists.txt
@@ -1,6 +1,7 @@
-add_executable(convert_nt_path convert_nt_path.cpp)
-target_link_libraries(convert_nt_path PRIVATE libnt_namespace)
+add_executable(nt_namespace_convert convert_nt_path.cpp)
+target_link_libraries(nt_namespace_convert PRIVATE nt_namespace)
+set_target_properties(nt_namespace_convert PROPERTIES OUTPUT_NAME convert_nt_path)
if(MINGW)
- target_compile_options(convert_nt_path PRIVATE -municode)
- target_link_libraries(convert_nt_path PRIVATE -municode)
+ target_compile_options(nt_namespace_convert PRIVATE -municode)
+ target_link_libraries(nt_namespace_convert PRIVATE -municode)
endif()